iOS - Using xcframework embedded returns - is unavailable: cannot find Swift declaration for this class

step
xcode
ios
#1

Bitrise Build Issue Report template

Description of the issue

I have been trying to build my project in Swift using Xcode with an xcframework inside the bitrise but I have been encountering problems.

After configuring my workflows, when compiling I get some errors like: is unavailable: cannot find Swift declaration for this class - From the files that are inside my xcframework.

When running the bitrise on my local machine, everything worked perfectly.

Environment:

Works fine on my MacBook, I’m using bitrise CLI, and works well.

Do not work on bitrise.io

Which build Step causes the issue and which version of the step?

Xcode Archive & Export for iOS v3.2.x

Reproducibility

Just let it build and when goes through Xcode Archive I received the error

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : YES
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Always happened

Local reproduction

If I run it locally, works perfectly

Local reproduction: Linux / Android (docker based) stack builds

Didn’t test, its an iOS App

Build log

0 Likes

#2

Hello there @fabriciomasiero :wave:

Can you please try running a clean build with the Bitrise CLI and attach the output logs from that build here please? :slight_smile:

We have guide on the topic here: https://blog.bitrise.io/post/how-to-debug-your-build-locally

0 Likes