iOS build question - could not build Objective-C module 'CommonCrypto'

Anyone else running into a problem here with CommonCrypto? This is on XCode 9 beta 6 and I’m seeing this error during the archive stage

“could not build Objective-C module ‘CommonCrypto’”

1 Like

Thanks for reporting, @kangaroo5383, we’ll check this asap!
Can you please attach to whole build log for context?


Hi @kangaroo5383,

Can you please share a bit more info? Particularly the step’s log would help a lot, where you get the error (the whole step log with the step’s header and footer, if possible), as well as the build config (bitrise.yml).

If you can’t share these publicly please send the build’s link/url to us through email or the onsite chat on!

1 Like

@daniel Thanks for the quick response, I’ve included the relevant info in a chat message and linked back here for context and reference. I am not able to share the logs publicly, but hopefully once we resolve the issue, we can post back here for others’ benefit!

1 Like

@daniel please don’t forget to share the solution here :wink:

Thanks for the reminder! So we figured out what the problem was. The xcode app path it assumed was incorrect for beta, so that’s why we were seeing this.

We added a script step and fixed it. However this is probably not needed since GM is out.

For future reference!
sudo mv /Applications/ /Applications/
sudo xcode-select -switch /Applications/


Thanks for posting the solution here @kangaroo5383 ! I’ve marked it as such so others would find it more easily.

1 Like

This is still happening.
We have a build using Xcode 9.1 and we see these errors all over the place. Is it expected to run the script above ourselves? Is there a solution internally at Bitrise for this?

Xcode 9.1 non beta just went live: Weekly Virtual Machine / Stack updates - 2017.11.04 - Xcode 9.1 final, Xcode 9.2 beta

Try a rebuild @bsarrazin and let us know if that wouldn’t help :slight_smile:

It worked! Thanks Viktor!


Any time :wink: