Failed to find development Xcode managed provisioning profile

ios-auto-provision
ios
#1

Bitrise Build Issue Report template

Description of the issue

We have a few apps that we build using bitrise, 2 of the apps that we build and upload work fine every time, however one of the apps fails every time saying;

“Failed to find development Xcode managed provisioning profile for bundle id: …”

I have used the “codesigndoc” on my mac and uploaded all the files that it exports, I have even created new profiles in the apple portal and manually downloaded and uploaded them to bitrise but still no luck, I can build and upload the app fine manually from xcode on my machine just not using bitrise, could someone help?

Environment:

Where did the issue happen?

| x | ios-auto-provision@1.3.1 (exit code: 1) | 39 sec |
±–±--------------------------------------------------------------±---------+
| Issue tracker: …github.com/bitrise-steplib/steps-ios-auto-provision/issues |
| Source: https://github.com/bitrise-steplib/steps-ios-auto-provision

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Never worked for this particular app

Local reproduction

Works fine locally

Build log

Sent in private email

0 Likes

#2

Just posting this here for other users’ reference:

Si and I managed to solve the issue by setting the “Should the step try to generate Provisioning Profiles even if Xcode managed signing is enabled in the Xcode project?” setting in the iOS Auto Provisioning step to “Yes”.

I recommend anyone experiencing similar issues also try this :wink:

0 Likes

closed #3
0 Likes