Ionic Build error: @ionic/cli-plugin-cordova outdated

ionic
#1

Hello,

I am trying to build an Ionic project, but i am getting this error on Ionic Archive:

[WARN] Error occurred during command execution from a CLI plugin
       (@ionic/cli-plugin-cordova). Your plugins may be out of date.
TypeError: env.runcmd is not a function

Yesterday it was working fine, but today is crashing.
Today we had an update on this package and in some others, maybe this could be the reason, but I tried to build with the old version and with the new, and I got the same error. I tried to build without Ionic Archive step, by command in script, and I got same error;

Changed packages:

  • @ionic/cli-plugin-cordova (1.5.0) -> (1.6.2)
  • @ionic/cli-plugin-ionic-angula (1.4.0) -> (1.4.1)
  • ionic (3.6.0) -> (3.7.0)

I am running build with:
Android & Docker, on Ubuntu 16.04

Could you see if something is going wrong with the npm/node of servers?

Thanks!

0 Likes

#2

The stacks are not updated during the week, only on weekends, so this definitely seems to be related to some code/dependency change in your project.

If you need more help please send us the build’s URL, here, through the onsite chat or via email, we’ll need the whole log. From what you copy pasted this seems to be an Ionic/Cordova (plugin) issue, probably a regression introduced in a new version.

0 Likes

#3

Note about the stack updates: any time we do any update on the stacks we publish it in the #changelog, with #stack-updates tag (https://discuss.bitrise.io/tags/stack-updates).

The last one was

and the next one will be (scheduled for tomorrow)

0 Likes