Failed to send command to cmd-bridge server

Bitrise Build Issue Report template

Job don’t start when I run two different workflow in same time (coming from GitlabCI)

Please describe the issue here


Where did the issue happen?

Visual Studio for Mac, installed on macOS 10.13 (High Sierra), set to the Stable channel.

Which build Step causes the issue and which version of the step?

E.g.: Before the first step of the workflow


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES
  • _Does a rebuild without caches help? : NO
  • Does the issue happen sporadically, or every time? : sporadically
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : since I’m doing two build in same time

Build log

2018/07/02 00:55:38 Failed to send command to cmd-bridge server: Post http://localhost:27473/cmd: dial tcp [::1]:27473: getsockopt: connection refused

Hey @odemolliensproximus !

Unfortunately we have this spot issue on this stack and we are working on it already. Sorry for the inconveniences! It should be fixed soon.


Fixed, thanks :slight_smile:

Getting the same issue, @tamaspapik is this fixed already?


@eamiguinho we rolled out the fix again, and we believe we now identified the root cause and fixed it, so it should not happen again (it’s a detail of how we do the virtual machine image updates, which requires a slight change in the Visual Studio stacks due to the VS4Mac updates have to be installed automatically, so we have to do that manually every week, while all other stacks’ update is fully automatic and does not have this issue). Sorry for the inconvenience.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.