Error on deploy-to-itunesconnect-deliver@2

deploy
ios
#1

Sometimes there is an error when deploying to itunes. Normally, rebuilding works again, but I’m missing builds on each error.

Step

deploy-to-itunesconnect-deliver@2.x.x

Enviroment

Stack: Xcode 11.7x, on macOS 10.15.6 (Catalina)

Build log

Full build log here

Apple recommends you don’t specify the -t transport and instead allow Transporter to use automatic transport discovery to determine the best transport mode for your packages. For more information, please read Apple's Transporter User Guide 2.1: https://help.apple.com/itc/transporteruserguide/#/apdATD1E1288-D1E1A1303-D1E1288A1126

[22:15:09]: Apple recommends you don’t specify the -t transport and instead allow Transporter to use automatic transport discovery to determine the best transport mode for your packages. For more information, please read Apple's Transporter User Guide 2.1: https://help.apple.com/itc/transporteruserguide/#/apdATD1E1288-D1E1A1303-D1E1288A1126

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.itmstransporter

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=com.apple.jingle.leghorn.software)(version>=2.1.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.aspera-macos-arm64

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(|(arch~=arm64)(arch~=arm64e))(rosetta=false))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.itmstransporter

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=com.apple.jingle.leghorn.media)(version>=2.1.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.itmstransporter

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=com.apple.jingle.leghorn.fileformat.impl)(version>=2.1.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.itmstransporter

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=org.apache.xmlbeans)(version>=2.5.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.core

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=com.apple.jingle.leghorn.fileformat.exceptions)(version>=2.1.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: unsatisfied requirement: com.apple.transporter.softwaresupport

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: (&(package=com.apple.jingle.leghorn.fileformat.exceptions)(version>=2.1.0)(!(version>=3.0.0)))

[22:30:14]: [iTMSTransporter] [2021-03-12 22:30:14 UTC] <main> ERROR: could not find the service with interface (com.apple.transporter.osgi.TransporterService)

[22:30:14]: iTunes Transporter output above ^

[22:30:14]: A downloaded software component is corrupted and will not be used. https://contentdelivery.itunes.apple.com/transporter/repositories/j2se8/2.1.0/bundles/com.apple.its.epubcheck-runner-4.4.1.jar

A downloaded software component is corrupted and will not be used. https://contentdelivery.itunes.apple.com/transporter/repositories/j2se8/2.1.0/bundles/com.apple.transporter.mediatoolkit-2.1.1.jar

unsatisfied requirement: com.apple.transporter.softwaresupport

(&(package=com.apple.transporter.mediatoolkit)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.jingle.leghorn.software)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.jingle.leghorn.media)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.jingle.leghorn.fileformat)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.softwaresupport

(&(package=com.apple.jingle.leghorn.fileformat)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.transporter.mediatoolkit)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.jingle.leghorn.fileformat.impl)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.softwaresupport

(&(package=com.apple.jingle.leghorn.software)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.jingle.leghorn.fileformat.exceptions)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.jingle.leghorn.fileformat)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.aspera-linux-x64

(&(osgi.native.osname~=Linux)(osgi.native.processor~=x86-64))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.transporter.mediatoolkit)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.jingle.leghorn.software)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.aspera-macos-arm64

(&(|(arch~=arm64)(arch~=arm64e))(rosetta=false))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.jingle.leghorn.media)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=com.apple.jingle.leghorn.fileformat.impl)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.itmstransporter

(&(package=org.apache.xmlbeans)(version>=2.5.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.core

(&(package=com.apple.jingle.leghorn.fileformat.exceptions)(version>=2.1.0)(!(version>=3.0.0)))

unsatisfied requirement: com.apple.transporter.softwaresupport

(&(package=com.apple.jingle.leghorn.fileformat.exceptions)(version>=2.1.0)(!(version>=3.0.0)))

could not find the service with interface (com.apple.transporter.osgi.TransporterService)

The call to the iTMSTransporter completed with a non-zero exit status: 1. This indicates a failure.

[!] Error uploading ipa file:

If you have issues, use the latest prerelease version of fastlane.

Set the fastlane version input to "latest" to enable prerelease versions.

Deploy failed, error: exit status 1
0 Likes