❌ error: exportArchive: No profiles for 'x' were found

ios

#1

Bitrise Build Issue Report template

Description of the issue

Greetings everyone.

I am running a working to deploy my app to applestore. Previously, it was working propertly. But since 2 days ago, when I try to deploy my app, the build fails and always shows :

Failed to find Codesign Groups

generated export options content:

<?xml version=“1.0” encoding=“UTF-8”?>

<!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”>

<plist version=“1.0”>

<dict>

<key>method</key>

<string>app-store</string>

</dict>

</plist> <nil>

:x: error: exportArchive: No profiles for ‘x’ were found

I already used codesign command to upload all provisionings and certificates to bitrise. Uploading .ipa from local environment using xcode worked normally.

Environment:

It happened when I am trying to build using bitrise

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

STACK: Xcode 10.0.x, MacOS 10.13

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? : everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? :
    2 days ago.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.


#2

Hi @luisjunior! Could you please also include a build URL about the issue?


#3

Sure @bitce
: https://app.bitrise.io/build/bb6aa28f73a6eb53

Thanks in advance,


#4

Thanks! Can you please also enable Support Access on the Settings tab of the app (https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/), so that we can look into its configurations?


#5

I started a chat with bitrise support and they helped me to solve the problem.

Basically: I turn on the option to recreate schemes on iOS Auto provision step…

But thanks anyway :slight_smile:


#6

Oh I see, glad to hear it was a fast resolution then! :slight_smile:


#7

I’m with the same problem.
@luisjunior. Could you help me?
Where is located the option Recreate Schemes inside iOS Auto Provision step?


#8

It’s not recreating schemes, but profiles, I believe @luisjunior is referring to this step input:


#9

Yes, that’s right. recreating profiles. Sorry about this misunderstanding…


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.