Could not resolve all files for configuration ':classpath'

Bitrise Build Issue Report template

Description of the issue

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all files for configuration ':classpath'.
   > Could not find lint.jar (com.android.tools.lint:lint:26.0.0).
     Searched in the following locations:
         https://jcenter.bintray.com/com/android/tools/lint/lint/26.0.0/lint-26.0.0.jar
   > Could not find sdk-common.jar (com.android.tools:sdk-common:26.0.0).
     Searched in the following locations:
         https://jcenter.bintray.com/com/android/tools/sdk-common/26.0.0/sdk-common-26.0.0.jar
   > Could not find builder-model.jar (com.android.tools.build:builder-model:3.0.0).
     Searched in the following locations:
         https://jcenter.bintray.com/com/android/tools/build/builder-model/3.0.0/builder-model-3.0.0.jar
   > Could not find annotations.jar (com.android.tools:annotations:26.0.0).
     Searched in the following locations:
         https://jcenter.bintray.com/com/android/tools/annotations/26.0.0/annotations-26.0.0.jar

Getting the error above while building our Cordova application. The same build configuration running on the same version of the code on Friday (25th of May) worked fine. Rebuilding it today triggered the error.

The build on Friday seemed to download these dependencies from maven.google.com while the build today tries to download them from bintray.com. Today’s build downloads other dependencies from maven.google.com, it just does not want to download these from there.

Environment:

Where did the issue happen?

On Bitrise.io using the Hybrid on macOS (stable) stack.

Which build Step causes the issue and which version of the step?

cordova-archive@1.1.1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : We do not use caches
  • Does the issue happen sporadically, or every time? : Seems to be every time (tried 2 builds).
  • Does upgrading the build Step to the latest version help? : It is using the latest version
  • When did the issue start? : Today

Hi!

There’s an ongoing jcenter.bintray.com issue which affects all Android package downloads from jcenter.bintray.com.

A simple and reliable mitigation can be to configure a Bitrise Build Cache for your Android project, so your dependencies are cached and don’t have to be downloaded from bintray. You can find a guide for the setup at: How to cache Gradle dependencies

1 Like

A rebuild today worked. I will add the cache steps. Thanks a lot for the help!

All right, I’m closing this thread but if you’d need any help feel free to contact us.

Happy Building! :slight_smile: