Conflicting provisioning profiles error

cordova
fastlane
#1

Bitrise Build Issue Report template

Description of the issue

I keep getting the error message:

[app] has conflicting provisioning settings. [app] is automatically signed for development, but a conflicting code signing identity iPhone Distribution has been manually specified. Set the code signing identity value to “iPhone Developer” in the build settings editor, or switch to manual signing in the Signing & Capabilities editor.

I’ve tried disabling automatic code-signing, and that meant I had to do everything Fastlane is supposed to do. So I tried disabling then immediately re-enabling automatic code signing as suggested here, and that just got me back to square one. I then followed this suggestion to use the Generate cordova build configuration step. I set automatic provisioning to true, and that still doesn’t get past the problem. Now I want to set it to false, but that means I have to programmatically match it to the provisioning profile that match has installed. I could hard-code this value, but that’s too brittle. Is there way to programmatically pass the installed profile from the Fastlane Match step to the Generate cordova build configuration step? I considered using an environment variable, and thought I could implement it in this way:

I have the app id saved in a secret variable named $APPLE_APP_ID. That should mean that inside the lane, the value of the provisioning profile would be lane_context[SharedValues::MATCH_PROVISIONING_PROFILE_MAPPING][$APPLE_APP_ID]. I could then export that as an environment variable that is used by the Generate cordova build configuration step. I haven’t tried this yet, partly because it just feels like such a hack. There must be a much more elegant way to solve this problem. Any ideas?

Environment:

Where did the issue happen?
On Bitrise.io

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)
Stack: Xcode 11.1.x, on macOS 10.14.6 (Mojave)

Which build Step causes the issue and which version of the step?

Fastlane 2.7.1

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : I’m on the latest
  • When did the issue start? : I haven’t gotten any successful ios builds, I’ve been solving other build problems, this is the latest one.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.
No I don’t have a Mac for local testing.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

Sent via email.

0 Likes

#2

Hi,
i am facing with the same problem, did you get any solution.

0 Likes

#3

Hi @Textras and @mihir! We’re happy to take a look in case you post a build URL here for us!

0 Likes

#4

Hi @bitce

Thank you for reply. Actually there was some problem in my side to setup in signing step so, i solved this issue and now it works :slightly_smiling_face:.

0 Likes