Codesigndoc signed .p12 fails to convert to pem

Hi Bitrise Team,

I have used the codesigndoc tool to generate my .p12 file and uploaded on Bitrise. However it seems like it fails to convert the .p12 file to pem file with the following log output. I will appreciate your help since this simple issue is blocking my company’s initial setup with Bitrise.

Just to clarify i also tried manually exporting my .p12 certificate with password and set password in the settings which also did not work. I also looked at your go code where the openssl command line tool is used, i have tried on my pc and managed to convert my .p12 certificate successfully with password and without password.


| (4) certificate-and-profile-installer@1.8.8                                  |
| id: certificate-and-profile-installer                                        |
| version: 1.8.8                                                               |
| collection:                |
| toolkit: go                                                                  |
| time: 2017-09-22T01:18:28-07:00                                              |
|                                                                              |
INFO[01:18:28]  * [OK] Step dependency (go) installed, available. 
 - CertificateURL: https://www.bit***803
 - CertificatePassphrase: 
 - ProvisioningProfileURL: file://Las***ile
 - DefaultCertificateURL: 
 - DefaultCertificatePassphrase: 
 - DefaultProvisioningProfileURL: 
 - KeychainPath: /Users/vagrant/Library/Keychains/login.keychain
 - KeychainPassword: ***
Provided Certificate count: 1
Provided Provisioning Profile count: 1
Keychain already exists, using it: /Users/vagrant/Library/Keychains/login.keychain
Downloading & installing Certificate(s)
=> Downloading certificate: 1/1
   Downloading (https://www.bit***803) to (/var/folders/90/5stft2v13fb_m_gv3c8x9nwc0000gn/T/bitrise-cert-tmp209348217/Certificate-0.p12)
=> Installing downloaded certificate
Failed to convert .p12 certificate to .pem file, out: 1432:error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag:/BuildRoot/Library/Caches/
1432:error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error:/BuildRoot/Library/Caches/, error: exit status 1
|                                                                              |
| x | certificate-and-profile-installer@1.8.8 (exit code: 1)        | 5.10 sec |
| Issue tracker: .../bitrise-io/steps-certificate-and-profile-installer/issues |
| Source: ...s:// |


- certificate-and-profile-installer@1.8.8:
    - certificate_passphrase: 
    - default_certificate_url: 
    - default_certificate_passphrase: 
    - default_provisioning_profile_url:

Hey @borg666 !

Could you please pass me the build’s url? So we can have a look. :blush:

Also, please continue the conversation in this topic: