"Check Pods Manifest.lock" always failed

Bitrise Build Issue Report template

▸ Running script '[CP] Check Pods Manifest.lock’
:x: error: The sandbox is not in sync with the Podfile.lock. Run ‘pod install’ or update your CocoaPods installation.
xcode test exit code: 65
xcode test failed, error: exit status 65
If you can’t find the reason of the error in the log, please check the raw-xcodebuild-output.log
The log file is stored in $BITRISE_DEPLOY_DIR, and its full path
is available in the $BITRISE_XCODE_RAW_TEST_RESULT_TEXT_PATH environment variable.

Description of the issue

Please describe the issue here
Build fails on “Check Pods Manifest.lock” all the time.
I’ve tried following steps but nothing changed.
Deleting the Podfile.lock file -> Deleting the Pods folder -> Execute ‘pod install’ -> Clean project from xcode
And the project works just fine locally on my mac.
Is there anything I am missing?


Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • If you have multiple different build configurations (workflows), does the issue affect all/more than one? : NO
  • If it’s an issue which happens sporadically, what’s the frequency? (e.g. Once a day ; about x% of the builds) :
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? :

Linux/Android stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Other stacks

Can it be reproduced by running the build locally with our CLI ( https://www.bitrise.io/cli ), after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )?

Build log

Please attach the build log (you can download the build log from the build’s page, once the build is finished, using the “Download log” button - floating at the bottom right corner of the log viewer), or if you can’t attach the whole log then send the full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related GitHub issue.

Hi @shen.yingyin,

Please follow this guide How to debug your build locally / "It works on my Mac/PC but not on bitrise.io" and let us know how it goes!

Actually, before that, please run a

pod update

in the repository on your Mac and commit & push the changes into the repository; that alone might help.

I did a clean clone and run pod update/install but it shows the same error.
By the way there is no any changes for me to commit after the pod update which because the whole Pods directory is ignored.
Should I add them as git tracking files?

@shen.yingyin do you mean you get the same error on your Mac?

That’s not an issue, Pods dir doesn’t have to be committed. The Podfile and the Podfile.lock should be committed.

One more thing, checking your linked build’s log: please move the Cache:Pull step before the CocoaPods Install step. Move it right after the Git Clone step.

With the current order cocoapods pod install will run, but than that will be overwritten by the cached Pods dir, pretty much invalidating the pod install.

Moved the step and yes! It works now!
Thanks so much :grinning:

1 Like

Glad to hear, Happy Building! :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.