Cannot upload to Test Flight with Zoom SDK

#1

I also reported this in the chat, but got no answer:
Hi, I have an issue with uploading to the store. I added Zoom SDK to our app, when uploading from my Mac it works OK, but when uploading through bitrise I get this error:
ERROR ITMS-90171: “Invalid Bundle Structure - The binary file ‘UnifiedApp.app/Frameworks/MobileRTC.framework/MobileRTC’ is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at https://developer.apple.com/go/?id=bundle-structure for information on the iOS app bundle structure.”

This is what I see when trying to upload xcarchive created by the bitrise build:

When trying to upload an xcarchive created locally with XCode10.3 command line, I see MobileRTC as a framework, not as an executable.
MobileRTC is the Zoom SDK

Environment:

iOS build The latest available Xcode 10.3.x (including betas), Android SDK and NDK, Cordova, Ionic, Flutter and Ruby (to support React Native) installed on macOS 10.14 (Mojave).

Step - Deploy to iTunes Connect - Application Loader version - 0.9.4

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : I don’t use the cache steps
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : After adding Zoom SDK

Local reproduction

Cannot reproduce locally - it works.

Build log

  1. datos-ios-unified
  2. build #1072
0 Likes

#2

Hi @Iditb!

Just following up to for everyone to see if they come across this thread, as I understand you’ve resolved this with Andrew through our chat and it turned out that a .plist was actually gitignored.

Glad to hear you guys were able to solve this! Let us know if anything is not up to speed :slight_smile:

0 Likes