ERROR ITMS-90189: Redundant Binary Upload

Description of the issue

The build fails to upload to TestFlight/AppStore due to receiving from AppStoreConnect the wrong build number.


I use Fastlane and it happened on the upload_to_testflight step. With the same fastlane setup, it was working before. This issue happened in the last 2…3 days.
I’ve tried to build with Xcode 11.2.x and 11.1.x and I get the same error.

Which build Step causes the issue and which version of the step?

fastlane 2.5.0 - upload_to_testflight step
with a newer version I cannot build at all because it cannot open the directory


  • Does a “Rebuild” help? : NO
  • Does a rebuild without caches help? : NO
  • Does the issue happen sporadically, or every time? : YES
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : 2…3 days ago

Local reproduction

I cannot try it.

Build log

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.