Cannot Start AVD

android

#1

Hi,

I am have this two steps for creating and starting android emulator but the start step always gets stuck at an error

Any idea why ANDROID_SDK_ROOT is missing?


#2

Hi there @vintwala, sorry to hear about the issue!

Could you please send us a build URL we could look into?


#3

Hi @bitce,

thanks for looking into this.
Here is one of the build:


#4

Of course and thanks @vintwala!

Unfortunately, I can not tell you exactly what is the issue, but through trial and error, I am 100% certain that it is caused by your Custom Hardware Profile Content input of the “Create Andriod emulator” step. Running the same hardware profile constantly fails for me as well, although I’m not sure just yet which line is causing this and why.


#5

Oh ok thanks. I will try out different hardware profile and check it out. @bitce


#6

Hi @bitce

So from my effort none of the hardware profile worked. Only if I leave it blank the emulator starts correctly. Although even after starting, the emulator is always stuck on a popup that says “System UI stopped working”. And thus none of my tests work.

I tried another approach to remove those two steps and use the AVD Manager step which completes successfully and producing the emulator serial but When I actually try to access anything using that serial, the emulator can never be found. Any idea why would that be?

Here are the builds with AVD manager step



#7

Thanks for the examples!

At the moment this appears to be a step issue on our end which we have started tracking and investigating. We will reply here to mention any progress and are really sorry about the inconveniences! Are there any other emulator options that would be suitable for you to work around this?


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.