Cannot finish to register an app via the api

#1

Hello,

I am trying to register an app via the api. It was working fine until yesterday.

Since Yesterday I cannot finish the registration. when I send a request to https://api.bitrise.io/v0.1/apps/APP-SLUG/finish, I get a 400 http error with this message {“error_msg”:“Failed to save project”}

The body is as follow:
{
“project_type”: “android”,
“stack_id”: “linux-docker-android”,
“config”: “default-android-config”,
“mode”: “manual”,
“envs”: {
“PROJECT_LOCATION”: “.”,
“MODULE”: “app”
},
“organization_slug”: “XXXXXXXXXXXXX”
}

I am not sure why I getting this error now. If anybody has an idea or knows the reason that would be great.

Thank you for your help in advance!

0 Likes

#2

Hello,

Are you still getting a 400 error? If so, can you please open developer tools and see if there is additional information provided as to the cause of the 400 error?

Thanks,
cathy

0 Likes

#3

Hi Cathy,

Thank you for your reply. I am still getting the 400 error with the same error message. No, there is no additional information I am afraid.

We tried to create an app with two different tokens created from two different accounts but we get the exact same error.

The thing that I find very odd is that the post requests to “https://api.bitrise.io/v0.1/apps/register” and “https://api.bitrise.io/v0.1/apps/APP-SLUG/register-ssh-key” work fine.

Thanks,
Xavier

0 Likes