Build fails when Xamarin.Android project target is API 26 (Oreo)

Bitrise Build Issue Report template

Description of the issue

When trying to build a Xamarin.Android project that targets API 26 (Oreo) build fails every time on Xamarin Archive step.


Stack osx-vs4mac-stable

Build Step: xamarin-archive (1.5.0)


Happens every time if project Target Platform is set to API 26.

Build log

Hi @XiteZ,

Did you test this on both the Stable and Beta channel stacks?

I’m getting the same issue. Tried on both stable and beta Xamarin channels.

Thanks for reporting!

We’ll add v26 preinstalled packages this weekend’s updates (

In the meantime you can either run these package installs yourself from e.g. a Script step, or target v25 until the weekend updates.

@XiteZ @mleatherb the updated Visual Studio for Mac stacks just went into production ( Weekly Virtual Machine / Stack updates - 2017.10.21 ); can you please try it again and let us know how it goes?


Seems to be OK, build works now :slight_smile:

1 Like

Glad to hear and thanks for reporting @XiteZ! :slight_smile:

Looks like it’s working now! Now to fix the unit tests Mono broke

1 Like