Build fails in android-build@1.0

Task :app:stripReleaseDebugSymbols FAILED
Support for ANDROID_NDK_HOME is deprecated and will be removed in the future. Use android.ndkVersion in build.gradle instead.
Task :app:mergeDexRelease
w: Detected multiple Kotlin daemon sessions at build/kotlin/sessions
FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:stripReleaseDebugSymbols’.

No toolchains found in the NDK toolchains folder for ABI with prefix: arm-linux-androideabi

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
  • Get more help at https://help.gradle.org
    Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
    Use ‘–warning-mode all’ to show the individual deprecation warnings.
    See Command-Line Interface
    BUILD FAILED in 2m 15s
    358 actionable tasks: 358 executed
    Run: build task failed: exit status 1
    | |
    ±–±--------------------------------------------------------------±---------+
    | x | android-build@1.0 (exit code: 1) | 2.3 min |
    ±–±--------------------------------------------------------------±---------+
    | Issue tracker: …thub.com/bitrise-steplib/bitrise-step-android-build/issues |
    | Source: GitHub - bitrise-steplib/bitrise-step-android-build |
    ±–±--------------------------------------------------------------±---------+

Hi,
Thank you for contacting Bitrise.

This root cause is that the ndk version in your project’s setting is different from the ndk version pre-installed on Bitrise stacks.

Currently, the pre-installed ndk version is 24.0.8215888 and you can check the system report for further details.

Here’re two ways to solve this issue:

  1. Update the ndk version to 24.0.8215888 in your project setting, or
  2. Install the ndk version you’re using locally with the Install missing Android SDK components step at the beginning of the workflow.

Besides that, you will also need to specify the ndk path for Gradle.

Using Android Gradle plugin before v3.5.0

You’d need a local.properties file and define the ndk.dir variable.
Since local.properties is not recommended to be stored in git, please add a script step after git clone step and use the following script to create a local.properties file.

#!/usr/bin/env bash
echo ‘Generating local.properties ...’
echo $ANDROID_HOME
cat > “./local.properties” <<- FILE_CONTENT
sdk.dir=$ANDROID_HOME
ndk.dir=$ANDROID_HOME/ndk/21.4.7075529
FILE_CONTENT

Using Android Gradle plugin v3.5.0 or higher

You’d need to define the ndkVersion in your build.gradle file.

android {    ndkVersion "xx.x.xxxxx" // e.g.,  ndkVersion "24.0.8215888"}

You can check Install and configure the NDK and CMake  |  Android Developers for further information.

Hope this helps!

Thanks,
Han

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.