Bitrise build ios fails - GoogleDataTransport

The iOS Build script on bitrise workflow of our cordova based app fails with this error during the archive phase:

The following build commands failed:
PhaseScriptExecution [CP]\ Copy\ Pods\ Resources /Users/vagrant/Library/Developer/Xcode/DerivedData/My_CA_Auto_Bank_App-clkbflfrjearhsheovhdpzzvywxq/Build/Intermediates.noindex/ArchiveIntermediates/My\ CA\ Auto\ Bank\ App/IntermediateBuildFilesPath/My\ CA\ Auto\ Bank\\ CA\ Auto\ Bank\ (in target ‘My CA Auto Bank App’ from project ‘My CA Auto Bank App’)
(1 failure)
xcodebuild: Command failed with exit code 65

The error that seems to cause the build to fail is:

error: Resource “/Users/vagrant/Library/Developer/Xcode/DerivedData/My_CA_Auto_Finance_App-ccylhdbrjibzdkfyuypforsjbhnw/Build/Intermediates.noindex/ArchiveIntermediates/My CA Auto Finance App/BuildProductsPath/Release-iphoneos/GoogleDataTransport/GoogleDataTransport_Privacy.bundle” not found. Run ‘pod install’ to update the copy resources script.

I have not made any changes to the pipelines or the stack. Rebulding the last successful build we have the same error.
I have tried to add a Cocoapod install before the build script in according to this doc Steps, to change xcode version, but nothing changes.
The only difference I’ve notices are the different Bitrise version and Agent version.

Can someone help me?


Hi @francesco.illotta - welcome to the Bitrise forum!

The best way to get this resolved is to raise a support ticket here -

And also enable support access so the support team can look at your app - Enabling the Bitrise Support Access for your app - Bitrise Docs

Thank you!