AVD manager stopped working

#1

id: avd-manager |
| version: 1.0.1 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |

Config:

  • AndroidHome: /usr/local/share/android-sdk
  • APILevel: 26
  • Tag: google_apis
  • DeviceProfile: pixel
  • CreateCommandArgs: --sdcard 512M
  • StartCommandArgs: -camera-back emulated -camera-front none -dns-server 8.8.8.8
  • ID: emulator
  • Abi: x86
  • EmulatorChannel: 0
    Update emulator

$ /usr/local/share/android-sdk/tools/bin/sdkmanager “–verbose” “–channel=0” “emulator”

Failed to run phase, error: exit status 1, output: Exception in thread “main” java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
at com.android.repository.api.SchemaModule$SchemaModuleVersion.(SchemaModule.java:156)
at com.android.repository.api.SchemaModule.(SchemaModule.java:75)
at com.android.sdklib.repository.AndroidSdkHandler.(AndroidSdkHandler.java:81)
at com.android.sdklib.tool.sdkmanager.SdkManagerCli.main(SdkManagerCli.java:73)
at com.android.sdklib.tool.sdkmanager.SdkManagerCli.main(SdkManagerCli.java:48)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
… 5 more

Thought it was a problem with the license, but accepting it does not help. Does anyone have ideas?

0 Likes