Appium iOS tests are returning false for visibility of elements

I have configured my appium tests on bitrise. But the tests are returning false for the visibility of elements. I have tried all type of configurations on my local and it’s functioning properly. Can anyone help on this as how to fix this problem or is there anything which I’m missing it.
Also, Same tests I have configured for android as well and they are running properly on bitrise.

Hi @Sumitbera,
sorry for the inconvenience!

Please attach your failed build url.
Have you tried to run your test using a simulator, which you recently reseted fully?

@godreikrisztian Hi,
Thanks for you support but I’ve managed to fix the problem. The issue was with the architecture of .app file which I was building for simulator.
I was building .app file with arch type i386 but managed to solve by changing it to x86_64. All this I get to know when I executed my bitrise.yml locally.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.