AppCenter App Release API call failed

#1

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here

id: appcenter-app-release
version: 1.0.5

API call failed with 410: {“code”:“gone”,“message”:"This API is deprecated. Please use the latest version of the App Center CLI: https://github.com/microsoft/appcenter-cli, … }

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : December 7

Build log

> `Starting AppCenter app upload at 2020-12-09T17:17:25Z
> API call failed with 410: {"code":"gone","message":"This API is deprecated. Please use the latest version of the App Center CLI: https://github.com/microsoft/appcenter-cli, or if you need a custom script please use the CLI as the basis for your implementation."}`
0 Likes

#2

Thank you for reporting this. Your builds should be working again. They’ve decided to undeprecate the API until February and in the meantime we’ll be working on a new step for this.

0 Likes

closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes