App Secrets not available in build

I have two secrets -


But, during the build time - I keep getting the error:


  • IpaPath: /Users/vagrant/deploy/Production.ipa
  • PkgPath:
  • ItunesconUser:
  • Password:
  • AppPassword:
  • AppID: 1454535343
  • BundleID: com.chefsplate.mobileapp
  • SubmitForReview: no
  • SkipMetadata: yes
  • SkipScreenshots: yes
  • TeamID:
  • TeamName:
  • Platform: ios
  • Options:
  • GemfilePath: ./Gemfile
  • FastlaneVersion: latest
  • ITMSParameters: -t DAV
    Issue with input: Password parameter not specified
    | |
    | x | deploy-to-itunesconnect-deliver@2.13.2 (exit code: 1) | 9.68 sec |
    | Issue tracker: …om/bitrise-io/steps-deploy-to-itunesconnect-deliver/issues |
    | Source: GitHub - bitrise-steplib/steps-deploy-to-itunesconnect-deliver: Deploy to iTunes Connect with Deliver |

Hi @adityac26,

It’s most likely a configuration issue. Did you specify $ITUNES_CONNECT_USER and $ITUNES_CONNECT_PASSWORD as the value in the deploy-to-itunesconnect-deliver step’s related inputs?

If you did not set these as the values then please do, otherwise the secrets won’t be set as the values in those inputs.

If you did and you can’t figure out why those are not set as the values, then please copy paste the related build’s URL, so that we can check the build’s logs & the config it was performed with and we’ll check it ASAP! :slight_smile:

I ended up resolving the issue by realizing that ITUNES_CONNECT_USER or any secret variables would not show up part of a PR. Which is sooooo weird! (@viktorbenei)

1 Like

Glad to hear you managed to resolve the issue!

Re: why are secrets by default are not available in PR builds you can find more info in the notice on the Secrets tab:

You can of course enable that specific secrets should be available in PR builds:

It’s disabled by default but can be enabled one by one for the inputs which you actually want to make available for PR builds.

If you’d have any questions just let me know! :wink:


Thanks @viktorbenei for the detailed answer.

1 Like

Any time :wink:

This topic was automatically closed after 13 days. New replies are no longer allowed.