Android emulator [AVD Manager] - Process system isn't responding

Android emulator fails when opening test app on device created using AVD Manager step: Process system isn’t responding

Description of the issue

Hi there, I am facing an issue where, for an emulator created through AVD Manager step, when app is opened on device, system fails with error ‘Process system isn’t responding’. Tried, from actual test code, to kill and restart the app, leading to same result.

AVD Manager configurations used:

Tried devices: Nexus or Pixel
Tried API Levels: 26 to 30
Tried OS tag: google_apis
ABI: x86
Create command: --sdcard 512M
Start command args: -camera-back none -camera-front none

For create/start these are the default args, tried to increase RAM with no luck. Weird thing is that one out of ~20 builds passed.

These are the desired capabilities that I am using at the moment, tried different variations:

adbExecTimeout: 300000
app: /bitrise/deploy/app-develop.apk
appWaitActivity: com.dozens.welcome.preauth.PreAuthActivity
automationName: UiAutomator2
deviceName: emulator-5554
enforceAppInstall: true
ignoreHiddenApiPolicyError: true
newCommandTimeout: 3600
noReset: false
uiautomator2ServerInstallTimeout: 360000

Will attach logcat records to this thread.


Also, Appium doctor, if useful:

appium-doctor --android --yes
info AppiumDoctor Appium Doctor v.1.15.3
info AppiumDoctor ### Diagnostic for necessary dependencies starting ###
info AppiumDoctor :heavy_check_mark: The Node.js binary was found at: /usr/bin/node
info AppiumDoctor :heavy_check_mark: Node version is 12.18.3
info AppiumDoctor :heavy_check_mark: ANDROID_HOME is set to: /opt/android-sdk-linux
info AppiumDoctor :heavy_check_mark: JAVA_HOME is set to: /usr/lib/jvm/java-1.8.0-openjdk-amd64
info AppiumDoctor Checking adb, android, emulator
info AppiumDoctor ‘adb’ is in /opt/android-sdk-linux/platform-tools/adb
info AppiumDoctor ‘android’ is in /opt/android-sdk-linux/tools/android
info AppiumDoctor ‘emulator’ is in /opt/android-sdk-linux/emulator/emulator
info AppiumDoctor :heavy_check_mark: adb, android, emulator exist: /opt/android-sdk-linux
info AppiumDoctor :heavy_check_mark: Bin directory of $JAVA_HOME is set
info AppiumDoctor ### Diagnostic for necessary dependencies completed, no fix needed. ###
info AppiumDoctor
info AppiumDoctor ### Diagnostic for optional dependencies starting ###
WARN AppiumDoctor :heavy_multiplication_x: opencv4nodejs cannot be found.
WARN AppiumDoctor :heavy_multiplication_x: ffmpeg cannot be found
WARN AppiumDoctor :heavy_multiplication_x: mjpeg-consumer cannot be found.
WARN AppiumDoctor :heavy_multiplication_x: bundletool.jar cannot be found
WARN AppiumDoctor :heavy_multiplication_x: gst-launch-1.0 and/or gst-inspect-1.0 cannot be found
info AppiumDoctor ### Diagnostic for optional dependencies completed, 5 fixes possible. ###

Which build Step causes the issue and which version of the step?
Emulator starts, but when Maven runs the tests and thus Appium connects to device and starts the app, step fails (step is a custom Script)


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO (already at latest version)
  • When did the issue start? : From the beginning of implementation, 3 weeks ago.

Local reproduction

No issues when running it locally

Local reproduction: Linux / Android (docker based) stack builds

Using Bitrise Cli, the emulator started by AVD manager is not responding, keeps loading and not responding.

Build log

Build log - Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation
Here, at the last step called ‘Update AVD Manager’, you can also see Logcat output.

I hope someone fixes this because I have the same issue. Occasionally it will work, but majority of the time the emulator does not respond. I’ve opened a ticket, but still no response back.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.