Xcode raw test result text path environement variable doesn't seem to be exported anymore

Bitrise Build Issue Report template

Description of the issue

step “deploy to bitrise” complain about empty “deploy path”.
This deploy path is fed by the var BITRISE_XCODE_RAW_TEST_RESULT_TEXT_PATH which is created by a previous “run Xcode iOS tests”.
This doesn’t seem to work anymore since yesterday.

Environment:

starting from yesterday

If on Bitrise.io: which stack?
No idea what this means. I’m running an iOS CI

Which build Step causes the issue and which version of the step?

Run ios tests version 2.7.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : yesterday

Local reproduction

_Can it be reproduced on your own Mac/PC by following our [local debug guide]
didn’t try, this worked well until yesterday

Local reproduction: Linux / Android (docker based) stack builds

didn’t try

Build log

Hello,

Could you enable support access for the app? You can find this under the “Settings” tab. Also, could you post the build url for where this behaved as you expected?

Thanks,
cathy

hi, i just enabled support access
here’s an example of a build that worked https://app.bitrise.io/build/34f73c3b-5458-466c-9a31-b0f1b9a63d4f#?tab=log