Xamarin Archive iOS - failed > failed to copy ipa

Hey!

However in the last xamarin-archive step the issue with // in paths is solved and now the generated ipa is found by the step easily:


But still this type of error occurs, this is the related part of an error log in this case:

Target _ZipIpa:
Zip Task
OutputFile: bin/iPhone/Release//SampleApp.ipa 

And fails almost with the same error message as before, but now the step can’t find the ipa because the ipa is not generated at all.

Regarding to these references:
https://bugzilla.xamarin.com/show_bug.cgi?id=41963
https://developer.xamarin.com/guides/ios/troubleshooting/questions/ipa-output-path/
https://forums.xamarin.com/discussion/67044/ipa-output-location
it seems like there is an issue with specific versions of Xamarin which generated the project, and there is a mistake in $(IpaPackageDir) variable.

Could anyone please direct me in the right direction how can I change it to make it build again?
Thank you! :ok_hand:

1 Like

These lines removed from .iOS.csproj file fixed the issue:

...

<CreateIpaDependsOn>
$(CreateIpaDependsOn);
CopyIpa
</CreateIpaDependsOn>

...

<Target Name="CopyIpa" Condition="'$(OutputType)' == 'Exe' And '$(BuildIpa)' == 'true'">
<Copy SourceFiles="$(IpaPackagePath)" DestinationFolder="$(OutputPath)" />
</Target>

...
1 Like