Test target encountered an error (Early unexpected exit, operation never finished bootstrapping - no restart will be attempted)

Bitrise Build Issue Report template

Description of the issue

Cannot bootstrap app for testing


OSX Xcode 9

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : The 3rd rebuild worked
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Sporadically
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : today 6/12/2017

Local reproduction

I’ve tried your suggested steps, but it passes on my mac.

Local reproduction: Linux / Android (docker based) stack builds

I’ve tried running it on a fresh clone with the bitrise cli and it passes everytime. Is their a way to debug the build folder? via ssh perhaps?

Build log

Hi @willmunn,

It seems you use fastlane to run your iOS tests.

Can you please try to run the tests with our Xcode Test step instead? Fastlane’s scan lacks a couple of issue detection features which our Xcode Test step has. E.g. our step can automatically do a retry on the test if it encounters an issue like yours, in case it’s most likely related to the iOS Simulator being not initialized in time. In that case a simple retry helps.

Anyway, can you please try it with our Xcode Test step and let us know how it goes?