React Native build fails for third-party install step

react-native
ios

#1

Bitrise Build Issue Report template

Description of the issue

Few days ago, last iOS builds don’t work with the following error:
error: Build input file cannot be found: '/Users/vagrant/git/node_modules/react-native/third-party/double-conversion-1.1.5/src/strtod.cc'

Local build works fine.

Environment:

Stack: Hybrid (Xamarin, Ionic) on macOS 10.13
Step: React Native bundle 1.0.3

Reproducibility

  • Does a “Rebuild” help? NO
  • Does a rebuild without caches help? NO (cache not used)
  • Does the issue happen sporadically, or every time? last 4 builds for iOS
  • Does upgrading the build Step to the latest version help? It’s latest
  • When did the issue start? oct 08 2018

Build log


#2

Hello there! The first thing I can suggest is, update bundler like gem install bundler.


#3

The problem is because we use Stack with stable channel. Apple did release iOS SDK 12, then inside stack, Xcode upgraded to version 10, and only React Native 0.57+ is compatible with this Xcode Version.

Changing to iOS stack with Xcode 9.4.x resolves the problem.


#4

Hello there! Glad you could solve it!


#5

@lucianomlima thanks for creating this issue and for posting the solution as well.

I ran into this issue and your solution of downgrading the stack to xcode 9.4.x worked! Thanks again!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.