Project evaluation failed including an error in afterEvaluate {}

Bitrise Build Issue Report template

Description of the issue

I am trying to create my first build from bitrise for android version in react native project. The app run on my local system perfectly. But it is stuck on “Install-missing-android-tools” with the error
“Project evaluation failed including an error in afterEvaluate {}”

  • What went wrong:

A problem occurred evaluating project ‘:app’.

> Could not read script ‘/Users/vagrant/git/Breath/node_modules/react-native/react.gradle’ as it does not exist.

  • Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.


Where did the issue happen?

It is on Bitrise.

Which build Step causes the issue and which version of the step?

install-missing-android-tools @ 2.2.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : On first build

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried. NO

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: . NO

Build log

Build url in private email will be sent.

Hello there!
I’m Sorry that you have difficulties, the link you provided is not the one we are looking for, could you send us the build’s url (like this: ?

1 Like

Problem solved!
The package.json was a folder deeper than the $BITRISE_SOURCE_DIR so the npm install could not do it’s work properly. added /Breath at the end of the env var and it solved the issue.

1 Like


Yes it has been resolved. Can you tell me how I can set env var myself if it happen in future for other projects.

Thank you so much for the quick help.

Hello there! In the workflow editor, there is an Env Var tab where you can set these variables.

Thanks got it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.