Problem with ionic archive, cannot find angular devkit

Hello, I’m trying to use ionic archive in a IOS build, but this error keeps happening

“An unhandled exception occurred: Cannot find module ‘@angular-devkit/build-angular/src/webpack/utils/helpers’”

I tried to build in a local computer and it works. So I’m really lost why this is happening, I already used the npm command to install angular-devkit but it didn’t resolve it. Someone have an idea of what i can do?

Hi @PabloSena,

Please try deleting your node_modules folder and running npm install to reinstall dependencies based on the contents of your package.json (this is what Bitrise does on the virtual machine).

If your build doesn’t work locally after this, it means you had installed a dependency without saving it to package.json. You can use npm install --save some-dependency next time to save the dependency and its version to package.json.

1 Like

This worked, thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.