Outdated analytics plugin

#1

Bitrise Build Issue Report template

Description of the issue

I am new to bitrise and have just taken over a project for our company after the original developer left.

After bitrise goes through the build processes for our ionic app, we get this message ->

Outdated analytics plugin, used format version is lower then host bitrise-cli’s format version, please update the plugin

I do not understand this message. I tried the instruction below ->

bitrise plugin install --source https://github.com/bitrise-io/bitrise-plugins-analytics.git

but this comes up with the error below ->

Plugin install failed, error: plugin validation failed, error: failed to get current version map, error: exit status 1

At this point, I just need a quick way to update this version. What should I do?

Environment:

This issue happened while building on bitrise CICD site

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : YES/NO
  • When did the issue start? :

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

I am not familiar yet with the process of building this locally with bitrise. The app can be build with regular ion build process.

Build log

Outdated analytics plugin, used format version is lower then host bitrise-cli’s format version, please update the plugin

Submitting anonymized usage informations…

For more information visit:

exit status 1

0 Likes

#2

Hy there👋

You don’t have to mind that warning, this will be fixed in the weekly VM updates :upside_down_face:
after CLI deploys this will be up for like a week.

1 Like

#3

same issue, any updates on react-native project ?

0 Likes

#4

Hi @benjipott, there’s no update we can provide unfortunately, but as mentioned above, this is not an error, this is a line printed out at the end of your logs as a warning. It does not affect your builds.

0 Likes