Missing Ruby 2.6.3 in Xcode 11.2.x stack

#1

Bitrise Build Issue Report template

Description of the issue

Today all our builds started failing with rbenv: version 2.6.3 is not installed error. We have this version set in .ruby-version file. When build is ran with remote access, we can indeed see that there is no 2.6.3 version installed:

vagrant$ rbenv versions
  system
  2.4.9
  2.5.7
* 2.6.5 (set by /Users/vagrant/.rbenv/version)

This is a breaking change and also does not match system report https://github.com/bitrise-io/bitrise.io/blob/master/system_reports/osx-xcode-11.2.x.log which lists 2.6.3 as not only available but a default one.

Environment:

Xcode 11.2.x stack

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : No
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : No
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : No
  • When did the issue start? : Today (2019-12-14)

Local reproduction

Not applicable

0 Likes

#2

We’re seeing the exact same issue. I’ve tried upgrading the stack to Xcode 11.3 to see if the issue was resolved, but it doesn’t seem so, the build fails with the same error.

0 Likes

#3

As quick solution, we bumped .ruby-version to 2.6.5 and it fixed the build.

0 Likes

#4

I’ve just made the change that @SebastianOsinski suggested and it seems to be working fine. Still, it’s odd that the system report states that 2.6.3 is installed when it’s not.

0 Likes

#5

Sorry guys, there were some issues related to the recent removal of OpenSSL 1.0 from brew which broke Ruby tools too, so we had to reinstall the Ruby versions and we opted to install the latest patch versions on the stacks. The system report you linked ( https://github.com/bitrise-io/bitrise.io/blob/master/system_reports/osx-xcode-11.2.x.log ) is now updated, the update of it was probably delayed (I don’t recall if it was & why, but it now lists 2.6.5 instead of 2.6.3).

1 Like

closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes