Key based cache not available for free plans?

Hi,
I’m trying to setup the Save and Restore cache steps as described in the docs but when I run the steps I get the message

Downloading archive...
download failed: failed to get download URL: HTTP 403: {"message":"Unfortunately, this step is not available on your current pricing plan. Please get in touch with us to resolve this."}

same for the Save Cache step:

Uploading archive...
cache upload failed: failed to get upload URL: HTTP 403: {"message":"Unfortunately, this step is not available on your current pricing plan. Please get in touch with us to resolve this."}

Another related question is about the cache key which does not seem to be computed correctly:

Evaluating key template: tuist-cache-{{ checksum "Tuist/Dependencies/Lockfiles/Package.resolved" }}
Build trigger doesn't have an explicit git commit hash, using the Git Clone Step's output for the .CommitHash template variable (value: 25b33f5c19764f6e156dbba25751abf091aeb2e3)
No files to include in the checksum
Cache key: tuist-cache-

even though the file does exist in the file system

To double check I added a step

    - script@1:
        inputs:
        - content: |
            #!/usr/bin/env bash

            file Tuist/Dependencies/Lockfiles/Package.resolved

which yields:

Tuist/Dependencies/Lockfiles/Package.resolved: JSON data

thanks in advance for your help

Hi, what plan are you on?

hey,
I’m on a Free plan

cheers

Could you share your org slug with me please? It should be in the URL

@kaushal.bitrise my app is on my personal bitrise account which is not an organisation

My personal account slug is 38e96b504645135b

A build where this occurs is

cheers

Using the branch base Cache push/pull actions works fine for me so I think I’ll stick with that caching

Strange. You should be able to use key-value cacheing. But we are unable to narrow down the root cause based on your account.

Are you able to enable support access for the affected app https://devcenter.bitrise.io/en/apps/enabling-the-bitrise-support-user-for-your-app.html

We could check the build logs and check if it’s to do with the builds themselves.

hey,
of course. I enabled the admin access for the support.

Thanks for looking into this :pray:

Build url still this one

Thanks. I’ve passed this onto our teams. Will share an update when we find something.

This should be now resolved.

Even though the user’s organization (named Prometheus) has access to Key-based caching, the app we are talking about does NOT belong to that organisation but to the user’s “personal workspace” (the user itself) called JanC which does not have access to key-based caching.

Resolution: We have enabled KV cache for your personal workspace. We would recommend that you add new apps to your organisation Prometheus to access key-based caching in future.

Thanks, it works as expected now :pray:

1 Like

Hi @kaushal.bitrise , I’m having the same issue here and I’m a new user here, can you help me take a look?