iOS: Successful Archive with Error of Exporting ipa from the archive

#1

Bitrise Build Issue Report template

Description of the issue

Despite having a successful archive - the attempted exporting of the ipa from the archive fails.
This works locally - and app has been manually uploaded from desktop to Testflight with no issues.

Please describe the issue here
Despite having a successful archive - the attempted exporting of the ipa from the archive fails.
This works locally - and app has been manually uploaded from desktop to Testflight with no issues.

Environment:

Xcode 11.3.1 on macOS 10.14.6 (Mojave)

Where did the issue happen?
After compiling successfully and archiving successfully.
Exporting ipa with ExportOptions.plist

No custom export options content provided, generating export options…

export-method specified: app-store

e[31;1mfailed to get target (TMRO-Sandbox) bundle id: xcodebuild “-project” “/Users/vagrant/git/TMRO/TMRO.xcodeproj” “-target” “TMRO-Sandbox” “-configuration” “Release” “-showBuildSettings” failed: exit status 74e

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?
Xcode 11.3.1 on macOS 10.14.6 (Mojave)

E.g.: Git Clone v3.6.0

Reproducibility

Always.

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
    NO.

  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
    NO

  • Does the issue happen sporadically, or every time? :slight_smile:
    NO - it happens always.

  • Does upgrading the build Step to the latest version help? : YES/NO
    NO

  • When did the issue start? :
    Build 1.

Local reproduction

NO - only on bitrise.

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.
NO.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Logs are: http://bit.ly/BLENG-BL266-Build-Logs

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

0 Likes

#2

Hi @duliodenis_bll, can you please send us a single build URL we can take a look at?

0 Likes

#3

Sure - https://app.bitrise.io/build/e3ab554523732fcc#?tab=log
This is Build 22

0 Likes

#4

Any update?

0 Likes

#5

any update?

0 Likes

#6

haven’t seen an update.

0 Likes

#7

Any update? It’s been well over a week.

0 Likes

#8

Two weeks with zero response.
I need to escalate this.

0 Likes

#9

Is anyone looking into this?

0 Likes

#10

Hi @duliodenis_bll, really sorry about the huge delay! We’re migrating ticketing systems and this caused a delay in replies on our public platforms

In case a problem you are experiencing is of urgent nature at all, please in all cases contact support directly on-site or at letsconnect@bitrise.io.

In any event, this thread was forwarded and will be attended soon.

0 Likes

#11

Unfortunately I have the same issue on my workflow that had always worked and now is broken.

I Have managed to go deeper into the issue and I believe it’s a problem with codesigning in xcode archive generation step:

  1. I deleted all certificates and provisioning profiles and updated all to Apple Distribution and Apple Development

  2. I created an exportOptions.plist that is in my folder

  3. I’ve specified wherever possible my correct parameters: app-store + Release

Unfortunately the step generates and Archive with this data (below) that results in the missing file Info.plist necessary to create a signed .ipa and deliver it via Deliver step.

team: [REDACTED]
profile: Bitrise ios development -  [REDACTED]
export: development
xcode managed profile: false (Actually in my project it’s set to automatic)

Could anyone please help me?

0 Likes

closed #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes

#13

@duliodenis_bll It seems your most recent builds are working as expected. Could you please share your solution here for the others who are experiencing it?

0 Likes

opened #14
0 Likes