Ineligible destinations for the "App" scheme

ios
#1

Bitrise Build Issue Report template

Description of the issue

Hi, it seems that the build is picking up automatically the first simulator available, so if you have a iPad only scheme, the build will fail with “Ineligible destinations for the App scheme” error.

Environment:

Where did the issue happen?

On bitrise.io, in the xcodebuild step

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Immediately

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Locally I can specify that I can run the scheme on iPad only.

0 Likes

#2

Hi, I solved by specifying explicitely the version of the simulator (iPad Pro (2nd generation)), while before it was set only to “iPad Pro”.

1 Like

#3

Got it, glad to hear you managed to solve the issue!

We’d still be interested in checking what the exact issue was, can you please share the bitrise.io build URL of the failed build? We’d check the logs & configs and schedule a bugfix for the step based on that :slight_smile:

0 Likes