How do I test my private step on bitrise.io?

#1

Hi Team,
I have extended one of the steps (swiftlint) and tested my changes locally using:

- path::./:

and it seems to work fine.

I followed the docs and then tried testing it by providing the address to the step in the repo, like this:

- git::git@github.com:lawicko/bitrise-step-swiftlint.git@output:

and it also seems to work just fine (BTW. you have a typo missing in the docs, the colon at the end is missing after the branch/tag specifier).

Following the docs, the next point is this:

Run a build with bitrise run or on bitrise.io to check if your Step worked.

Unfortunately, the docs don’t say how to do this exactly, but I managed to do it by changing the git to https and also a slash before my username instead of colon, so far so good. Now, when I tested locally, I got this output from my modified step in the console:

Loading configuration from ‘/Users/jakub/Documents/Project/bitrise-step-swiftlint/Test/TestConfig/.swiftlint.yml’
Linting Swift files at paths
Linting ‘Test.swift’ (1/1)
Done linting! Found 1 violation, 1 serious in 1 file.
Saved swiftlint output in SWIFTLINT_REPORT
Saved swiftlint output in file, it’s path is saved in SWIFTLINT_REPORT_PATH

However, when I run this on bitrise.io, there is no output:

Why is that? What am I missing?

0 Likes

#2

Ok I just figured it out, I just forked the repo today but yesterday there was another pull request accepted into the repo, and it contains one additional property for that step without the default value. I was not aware of this property. In the sources I found that it this new property has no value, the script will do nothing, which is exactly what I’m observing :crying_cat_face: I’m gonna go file a bug against the step original repo, you can close this.

0 Likes

closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes