Git status step failing with unsupported protocol scheme while updating in Github Enterprise

#1

Bitrise Build Issue Report template

  1. Have followed steps to configure GitHub Enterprise (GHE) private repository using environment variable.
  2. To update the build status in GHE private repo, added the git status step as mentioned in How to register a GitHub Enterprise repository
  3. See the below error:
    ------------------------------------------------------------------------------+

| (10) github-status@2.2.2 |
±-----------------------------------------------------------------------------+
| id: github-status |
| version: 2.2.2 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: bash |
| time: 2019-08-13T20:27:32Z |
±-----------------------------------------------------------------------------+
| |
config:

  • AuthToken: [REDACTED]
  • RepositoryURL: https://username:[REDACTED]@abc.xyz.com/xxx/repo.git
  • CommitHash: 123abc
  • APIURL:
  • State: auto
  • BuildURL: https://app.bitrise.io/build/30b60084ed619bc9
  • StatusIdentifier: continuous-integration/bitrise
  • Description:
    Error: failed to send the request: Post /repos/[REDACTED]@abc.xyz.com/xxx/statuses/6f0d675ca893fc1cc7bb8667f86bf2cc867363e7: unsupported protocol scheme “”
    exit status 1

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? Xcode 10.2 on Mac OS 10.14 (Mojave)
If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?
Git status v2.2.2

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) :NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : Already in latest version
  • When did the issue start? : Right from the first time configure git status in the workflow.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

– As Bitrise cannot send the build status back to GHE private repository, as suggested with the workaround, trying to work with git status

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

https://app.bitrise.io/build/30b60084ed619bc9#?tab=log

Also, please let me know if this works for GHE private repos as well:
https://devcenter.bitrise.io/builds/bitrise-checks-on-github-checks/

=================================================================
Also, in Account settings, can I configure to connect to GHE account rather than GitHub account, as my repos are in GHE but not in GitHub.
Please assist.

P.S - I tried multiple times to connect to GHE account, but it was redirecting to GitHub account leading to failure of “Test the git connection”.
“Error: No API integration for git hosting service yet. For more information check out this guide.”

0 Likes

#2

Hi @sowjanya-gurajada-Mi!

It’s hard to tell this based on the log alone, but from the @ character in the middle of the address I suspect there might be something wrong with that. You’d need something like this here:

https://github.XXX.com/XXX/XXX_iOS.git

Can you try that?

Bitrise Checks does not work with GitHub Enterprise unfortunately.

0 Likes

#3

Hi Bitce, tried that as well, still see the same error.

Also, can you please confirm if I can configure Github Enterprise account in my account settings instead of GitHub account, so that when I enable GitHub it can connect to GHE repo.

0 Likes

#4

Hi @sowjanya-gurajada-Mi,

You can not connect a GitHub Enterprise account in the way you’ve described it. You can only connect to your GHE repo via the URL. Can you please send us a build URL for this method you mentioned you’ve tried too?

0 Likes

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes