Docker failure for Android builds

docker
android
#1

Bitrise Build Issue Report template

Description of the issue

Docker fails to launch bitrise on Android builds.

Environment:

Where did the issue happen?

Bitrise.io: Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

docker: Error response from daemon: OCI runtime create failed: container_linux.go:348: starting container process caused “exec: “bitrise”: executable file not found in $PATH”: unknown.
time=“2019-01-22T18:52:39Z” level=error msg=“error waiting for container: context canceled”
exit status 127

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : EVERY TIME
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : After 10:46 AM EST

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

NO

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Haven’t tried.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

Send via private chat.

0 Likes

#2

Hello there!

Sorry for the late response, is it still occurring?

0 Likes

#3

Hello, no thank you! It was corrected from a discussion on the live chat, there was a rollback.

0 Likes

closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes