Detox (Test) failing

react-native
#1

Bitrise Build Issue Report template

Description of the issue

I’m trying to get Detox to run. Builds and tests fine locally through the Bitrise-cli, but when I try to run detox test --configuration ios.sim.release --cleanup after successfully building on the platform I keep getting this error:

detox[10630] ERROR: [exec.js/EXEC_FAIL, #7] "/bin/cat /dev/null >/Users/vagrant/Library/Developer/CoreSimulator/Devices/68D1A658-61BF-424C-A633-DF6C3D6FEB0E/data/tmp/detox.last_launch_app_log.out 2>/Users/vagrant/Library/Developer/CoreSimulator/Devices/68D1A658-61BF-424C-A633-DF6C3D6FEB0E/data/tmp/detox.last_launch_app_log.err && SIMCTL_CHILD_DYLD_INSERT_LIBRARIES="/Users/vagrant/Library/Detox/ios/6f933fef7d06549e6accd46fdde434f6dd3576cd/Detox.framework/Detox" /usr/bin/xcrun simctl launch --stdout=/tmp/detox.last_launch_app_log.out --stderr=/tmp/detox.last_launch_app_log.err 68D1A658-61BF-424C-A633-DF6C3D6FEB0E com.App --args -detoxServer ws://localhost:49405 -detoxSessionId 8b851442-2503-9e51-6f29-248421c0d458" failed with code = 1, stdout and stderr:

detox[10630] ERROR: [exec.js/EXEC_FAIL, #7] com.App: -1

detox[10630] ERROR: [exec.js/EXEC_FAIL, #7] An error was encountered processing the command (domain=FBSOpenApplicationServiceErrorDomain, code=1):
The request to open "com.App" failed.
The request was denied by service delegate (SBMainWorkspace) for reason: NotFound ("Application "com.App" is unknown to FrontBoard").
Underlying error (domain=FBSOpenApplicationErrorDomain, code=4):
	The operation couldn’t be completed. Application "com.App" is unknown to FrontBoard.
	Application "com.App" is unknown to FrontBoard.

Immediately causing my tests to fail. I cannot reproduce this locally. Any help would be appreciated.

Environment:

Standard Machine, Xcode 10.2.x, on macOS 10.14 (Mojave)

Which build Step causes the issue and which version of the step?

detox test --configuration ios.sim.release --cleanup

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : EVERYTIME
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Since introducing Detox

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

_Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? No

If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? No

Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ ._

0 Likes

#2

Hi @Alexandra.Moss!

Sorry to hear about this! Can you please also include an URL for a build where this issue is happening so we can check out the logs completely?

0 Likes

#3

Hi @bitce!

Thank you for responding, it’s been a frustrating two weeks of trying to figure this out. I actually was able to fix the problem. For whatever reason bumping up the appsimutils version fixed it, with:

brew install applesimutils --HEAD

Builds are successful again.

1 Like

#4

Awesome, great work! :slight_smile:

0 Likes

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes