Deploy to iTunes Connect / TestFlight (with Deliver) Fails

I receive the following error: “Could not find option ‘email’ in the list of available options…” I’ve looked through my Bitrise YML and don’t have any “email” options listed anywhere, I don’t see the email option being used in the fastlane command, and I don’t see any email options in the Deploy step UI.

Deploy to iTunes Connect / TestFlight (with Shenzhen) works just fine, but I’d like to use Deliver.

Here is the related snippet from my build logs:

$ fastlane “deliver” “–username” "iosdev@company.com" “–app” “1234123412” “–ipa” “/Users/vagrant/deploy/App-Nightly.ipa” “–skip_screenshots” “–skip_metadata” “–force” “–submit_for_review”

[!] Could not find option ‘email’ in the list of available options: username, app_identifier, app, edit_live, ipa, pkg, platform, metadata_path, screenshots_path, skip_binary_upload, skip_screenshots, app_version, skip_metadata, force, submit_for_review, automatic_release, price_tier, build_number, app_rating_config_path, submission_information, team_id, team_name, dev_portal_team_id, dev_portal_team_name, itc_provider, overwrite_screenshots, app_icon, apple_watch_app_icon, copyright, primary_category, secondary_category, primary_first_sub_category, primary_second_sub_category, secondary_first_sub_category, secondary_second_sub_category, app_review_information, description, name, keywords, release_notes, privacy_url, support_url, marketing_url

Deploy failed, error: exit status 1

That’s strange. Can you please send us the whole build log through email / the onsite chat?

I’d say this might be a deliver issue, maybe a faulty update from them…
I’d suggest you to create a github issue on their issue tracker too, they might be able to help faster than we are.

P.S.: I just ran a test with this step and it was successful :confused:

Problem solved. Running fastlane env from the pre-issue check list on Fastlane’s github page revealed some old files hidden in our app directory. A previous dev in our organization tried using Fastlane before the days of Bitrise and these files were interfering with the Deliver step. One of the fastlane files contained, you guessed it… an environment variable named ‘email’. Hence the error.

1 Like

Thanks for reporting @jvallely! :slight_smile: