Could not read from remote repository


I set up an integration with my self-hosted gitlab, but when I created a new app in the Configuration Application step, I ran into the problem “ssh: connect to host xxxx.xxxx.xxxx, port 22: connection timed out”.

fatal: Failed to read from remote repository. "

I know what the problem is - my gitlab ssh://git@xxxxx.xxxx.xxxxxx:2222 repo is using port 2222, it needs port 22 in the configuration step.

How can I change the port to 2222 in settings?