Choosing linux stack results in Xcode 11.7 stack used

Bitrise Build Issue Report template

Description of the issue

I attempted to switch stack for some workflows to Linux, but when it runs, the Xcode 11.7/Catelina stack is used. I tried using linux as the default with the same results. For workflows with Xcode 13 stack specified, that stack is properly set

Environment:

bitrise, “which stack?” is the issue, it builds with a stack not specified

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

the wrong stack is used before any steps start

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : when trying to use the linux stack

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.
not relevant

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .
not relevant

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.
Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation

Hello,

Are you still having this problem? If so, I think it might be best to open a ticket with support. Please provide a build URL that shows this problem and enable support access (under the “Settings” tab).

Thanks!
Cathy

Ok, thanks Cathy, I opened a ticket from your support page. I have to say it is disappointing that it took three days to let me know this was the wrong place for this kind of issue