Cannot connect to the FTP server

ftp
#1

I have a problem using Ftp Upload: cannot cannot to the server with “EOF” error message.
The server is Filezilla sftp server with basic mode for security. Is there some setting I need to set on the server side?

Here’s the bitrise log:
±-----------------------------------------------------------------------------+

| (1) ftp-upload@2 |
±-----------------------------------------------------------------------------+
| id: ftp-upload |
| version: 2.1.5 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2021-02-25T09:55:01Z |
±-----------------------------------------------------------------------------+
| |
INFO[09:55:01] Start installing (golang) with apt-get
INFO[09:55:01] * [OK] Step dependency (go) installed, available.
Configs:

  • HostName: [REDACTED]
  • Username: ***
  • Password: ***
  • SourcePath: test.txt
  • TargetPath: /CL-App-Releases/Android/bitrise-test.txt
    Connecting to server…
    2021/02/25 09:57:04 <
    Failed to connect to the ftp server, error: EOF
    | |
    ±–±--------------------------------------------------------------±---------+
    | x | ftp-upload@2 (exit code: 1) | 2.1 min |
    ±–±--------------------------------------------------------------±---------+
    | Issue tracker: https://github.com/bitrise-io/steps-ftp-upload/issues |
    | Source: https://github.com/bitrise-io/steps-ftp-upload |
    ±–±--------------------------------------------------------------±---------+
0 Likes

#2

HI @pavel.budanov!

Sorry to hear about issue. Is there any way you can send us an URL to the build and enable Support User access? This can be done in the Settings. It would also be helpful to learn the context about the host you’re trying to reach, are there any restrictions in place like a Firewall?

0 Likes

#3

Hi,
Good to see you, Bence.

Here’s the build URL - https://app.bitrise.io/build/446e68e088587b9f
Support User access enabled.

As the host maintainer says, it’s simply a Filezilla sftp server with basic mode for security, no firewall: 52.166.50.168:990
Let me know if you want me to send you credentials somehow w/o publishing it here.

0 Likes

#4

Thanks @pavel.budanov,

I highly suspect that address to be the problem. As the example suggests, ftp servers host names are usually in the following format:

ftp.servername.com:portnumber

Moreover, if I try to ping the address you provide here, I get ping: cannot resolve 52.166.50.168:990: Unknown host both on my local machine and on the build machines.

0 Likes

#5

Hi again,

It appeared there’s indeed Azure firewall there which blocks ping.

But I still can connect to that server using Filezilla FTP client.

It might be python ftp client used by Bitrise does not support session reuse that is required by Filezilla server: https://stackoverflow.com/a/45887654/639183
If that’s the case, you might file an improvement for it based on this answer https://stackoverflow.com/a/43301750/639183

In the meanwhile, I’ll try to convince our server team to soften server requirements.

Thanks.

0 Likes

closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes