Bitrise Start Build starts itself ! (infinite loop)

step

#1

Hi,

Today I configured a new workflow with the parallel “Bitrise Start Build” (very cool and awaited feature btw thank you). I noticed that my build #1 which starts builds #2 and #3 was lunching itself as well. That lead to have another build #1 starting number #2 and #3 in an inception-like scenario…

I noticed that in the field “Workflows” of my #1’s “Bitrise Start Build” I left an extra trailing blank line:
"#1
#2

"
So… either their is a problem with “Bitrise Start Build” itself or an extra blank line means “start yourself” (which is also a problem right ?)?

Thank you for your answers !


#2

Are you sure that you don’t use the same workflows? That you don’t trigger a build with the workflow which includes the “Bitrise Start Build” step?

Can you please copy paste the related builds’ bitrise.io URLs?


#3

I am sure yes. It worked just by removing the extra blank line.


#4

Did you figure it out what caused it?

If you’d still need help with this can you please copy paste the related builds URLs, so that we can look into the logs & configs?


#5

Yes as I said, the extra blank line in the field “Workflows” of my “Bitrise Start Build" step caused it. Removing it solved the problem. I’m not too sure I want to reintroduce that line (that I don’t need) it in order to check if that behaviors is still in place ^^ If I find it I’ll communicate you the build number before the extra blank line removal.


#6

Sure, no rush. We’ll try to reproduce the issue - will let you know if we can or if we need more information! :wink:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


#8

Hi @egirot,

We have rolled out a new release to fix this issue. Many thanks for taking the time to report it! :slight_smile: