All builds suddenly failing on activate-ssh-key step

#1

Bitrise Build Issue Report template

Description of the issue

Any build will now fail on the first step with:

ERRO[14:56:07] Step (activate-ssh-key@4) failed: EnvmanJSONPrint failed, err: Error: exit status 1, details: FATA[14:56:07] Failed to convert envs, error: setenv: invalid argument.

Environment:

Where did the issue happen?

Any Bitrise workflow we are using, any environment.

Which build Step causes the issue and which version of the step?

Activate SSH key (RSA private key) 4.0.5

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : it happens for every build, every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Feb 19th 2021

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

I wasn’t able to open a ticket. It keeps asking me to log-in.

0 Likes

#2

Hey @george.crecoukias,

The ticket login issue has been fixed, please try opening a new support ticket now. Sorry for the inconvenience!

If you enable support access, we can take a look at your build logs and config.

0 Likes