2FA still not working despite connecting Apple Developer Account

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here
My iOS builds keep failing because of the 2FA prompt despite already connecting the Apple Developer Account to Bitrise.


Where did the issue happen?
On Bitrise.io
Stack: Xcode 11.1.x, on macOS 10.14.6 (Mojave)

Which build Step causes the issue and which version of the step?
Fastlane v2.7.1
I use it to upload to testflight using fastlane’s upload_to_testflight action.

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : EVERY TIME
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : it’s always been there. I’ve never gotten past it.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

No it can’t be reproduced because I don’t have a Mac for local testing.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

No, see above.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.

Can’t share the URL. How can I get it to you? The last time I created a post and sent the URL in an email, I didn’t get a response by email and the person who responded to the post appeared to not have seen my email.

Hi @Textras,

Please open a ticket to our email support by going to https://bitrise.io/bitrise-support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.