Waiting for emulator to boot failes

emulator
android
#1

When i’m building the ‘wait for android emulator’ step files with error message:

Failed to check emulator boot status, error: * daemon not running; starting now at tcp:5037

Stack: Android docker on Ubuntu 18.04
Standard machine
cleared my cache

6 Likes

#2

same issue here! We didn’t changed anything but we are getting this error over and over again

0 Likes

#3

Same, it was working on Friday, today it’s terminating showing 90min limit with wait for emulator step failing.

When we remove the waiting step we’re left with:

Caused by: com.android.builder.testing.api.DeviceException: No connected devices!
1 Like

#4

I’m gonna add a “me too” here.

Our build is broken, we’re back to the dark medieval ages running tests locally.
It would be great to have a response from the bitrise team.

0 Likes

#5

Hi @DaanGeurts,
Thanks for reporting the issue! Could you please check if you also get the issue using the android LTS stack?

0 Likes

#7

Hi @tamasbazsonyi,
I’m getting this problem on Ubuntu 16 LTS also, so switching environments doesn’t work for now…

0 Likes

#8

Hi @DaanGeurts, @sb_ronaldopace, @StanislawGwara, @mirko.haeberlin,

We are trying to find a solution that would work without reducing the functionality of the AVD Manager step, but it proves to be more complicated than expected. It appears there is a workaround though. Could you do the following and start a new build?

  • Setting Verbose Mode in the Customize section of the AVD Manager step to false
  • Downgrading the AVD Manager step to version 0.9.1
2 Likes

Wait for Android emulator always failing
#9

Hi @tamasbazsonyi
I will give this a shot today

0 Likes

#10

that works for me

1 Like

#11

Great! I’m really happy to hear that! Thank you for confirming @mirko.haeberlin! :slightly_smiling_face:

1 Like

#12

@tamasbazsonyi I can confirm that these steps do work!!! Thanks for your help.

1 Like

closed #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes