Sometimes text is illegible in build log

I have noticed when using recently that sometimes when I get down a few screens on a very long log, it doesn’t render the background correctly. Sometimes this seems to be triggered by resizing the window, other times it happens on initial page load. I think I’ve only seen it for running builds. Sometimes reloading fixes it, sometimes not.

It appears to fix itself after the build finishes.

Hovering over a line of text causes the background to render under just that line. All the text is there (EditSelect All allows it to be seen) - it’s just impossible to read over the grey background:


Encountering the same thing, on every build.


I’m seeing this issue frequently as well.

1 Like

Thanks for reporting, we’ll try to fix this ASAP!


Is there any update on this? I try to diagnose Xamarin builds and they’re used to have very long outputs :confused:

Hi @dominik.roszkowski, this specific issue doesn’t seem to be present anymore, what are you experiencing exactly?

When observing build log live during the build sometimes (when it reaches thousands of lines) it gets hidden. Issue is similar to the OP’s problem - I can copy all the text to clipboard and paste it outside the browser but it’s invisible on the build page. Please see the screenshot attached:

Although output log div gets higher, the log is not visible.

1 Like

Oh, I see what you mean @dominik.roszkowski, thanks for detailing! We are aware of this unfortunate behaviour and are working on a long term fix! :slight_smile:


I am also getting this issue now. It’s even worse than the previous incarnation of this bug, since highlighting the text has no effect:

In the meantime I am using terminal to view logfiles. (This is sometimes faster than trying to browse the full log via website in any case.) I created a bash alias for macOS that will cat the most recent downloaded log file so ANSI colors are displayed properly:

alias catlog='cd ~/Downloads && ls -t|grep '\''log$'\''|head -1|xargs cat'
1 Like

Hi, the problem is still there. Is there any chance to implement fix soon?

Hi @dominik.roszkowski!

The web-site team is definitely working on this, bear with us!

1 Like

@bitce any ETA on the fix?

Hey guys,

Sorry for the delay (@Siemman) but this problem should be entirely solved since yesterday, let us know if you experience any similar troubles with the logs showing up and thanks for all your patience so far!

works now, thanks for the info :slight_smile: